https://thejuraku.com/pc/?p=12348

サーバーの PHP バージョンは 5.4.45 ですが WordPress 5.6 は 5.6.20 以上のみでご利用になれます。

WordPress Logo
Your server is running PHP version 5.4.45 but WordPress 5.6 requires at least 5.6.20.
サーバーの PHP バージョンは 5.4.45 ですが WordPress 5.6 は 5.6.20 以上のみでご利用になれます。

クライアントのサイトを同じドメインの中で移動したが、データベースなどは新しく作ったときに発生しました。

WordPress 5.2ではPHP 5.6以上が必須らしいのですが、現在のレンタルサーバーへ移動した時は昨年の9月頃でしたので既にWordPress 5.2以上だったはず。

今回はDuplicatorで以下の様に移動しましたが、同じサーバーでしたのですんなり行きましたね。

その前まではXAMPPにてテストサイトを作り、クライアントに確かめてもらいながらmixhost上で仮環境、クライアントが自分でレンタルサーバーを借りるという事でやっとhostgatorに移ったりとレンタルサーバー屋さんたちはだいたいPHPやMySQLをアップグレードしてくれていたので問題なかったですね。

たま~に、昔からどっかのレンタルサーバーで借りているお客様がいまして、昨年やっと重い腰を上げてくれ、違うレンタルサーバー屋へ移動する事ができました。そこのクライアントが借りていた前のレンタルサーバー屋では何故か既に何年もphpやSQLをアップグレードせずに運用していましたので何度かウイルスアタックを食らったりし、その都度修復という作業を行うことに。

なので、常に最新でないにしても、ほぼ最新の状態にphp、SQLなどをアップグレードしてくれる「普通」のレンタルサーバー屋は安心しますね。

話は長くなりましたが、上記のエラーがWordPressから出力されるときは素直にその通りに従うか、従いたくないならWordPressをダウングレードするしか有りません。

WordPressをダウングレードする時は普通に古いWordPressをアップロードするだけでダウングレードできるときもあれば専用のダウングレード用のプラグインを使用してダウングレードするしか無いときがあります。

もし、上記エラーが出てWordPressの管理画面にさえ入れない状況ならXAMPPでもどっかの違うレンタルサーバーででも良いので一度サイトを展開してダウングレードを行ってから本番環境に移すしか有りませんね。

あ、気づきましたか?記事が少しでも役に立ったと思ったらシェアでもコメントでもしてみてください^^;
スポンサーリンク
このページの短いURL: https://thejuraku.com/pc/?p=12348